Ember update not updating to latest version of branch


#1

I’m am still trying to get my project to stick with the LTS channel. currently, according to https://emberjs.com/builds/ the LTS version is 3.4.7

However, when I try ember update --to 3.4.7 I receive a git error regarding “unknown revision or path not in the working tree.” When I edit my package.json and set “ember-cli”: “3.4.7”, and then run yarn, I am asked to choose a version of ember-cli because 3.4.7 is not an option.

Obviously I am doing something wrong, and if anyone can point me to documentation or a tutorial on how to use ember with a specific channel (preferable LTS), I would be extremely grateful.


#2

The highest patch version I’m seeing for ember-cli and ember-source is 3.4.3, not sure why the LTS page says 3.4.7… What I typically do is just ember update --to ~3.4 which gets the highest patch within the minor range. So if you know LTS is 3.4 it will get the latest 3.4 patch.


#3

Interesting. When I use ember update --to ~3.4 I am getting v3.4.4


#4

:thinking: :man_shrugging:


#5

This definitely looks like an error. The latest release should be (as far as I can see) 3.4.6 (https://github.com/emberjs/ember.js/releases/tag/v3.4.6).

I’ll look into the issue and provide a fix. Thanks for reporting it @jezra!

Edit: Hmmm. 3.4.7 does exist… https://github.com/emberjs/ember.js/tree/v3.4.7


#6

So, it looks like there is no 3.4.7 for Ember CLI but the latest corresponding LTS version is 3.4.4 as it resolves to when running ember update --to ~3.4. I guess the communication on this needs to be a bit more clear.

When using ember-cli-update it is only considering the ember-cli version as input.


#7

I guess I am just confused as to what Ember 3.4.7 actually represents.


#8

Yeah it’s a bit confusing. Ember 3.4.7 is the latest LTS of ember-source while 3.4.4 is latest LTS version of ember-cli.


#9

compounded with the lack of documentation regarding how to use Ember LTS, it is quite confusing indeed.