Upgrading application to 3.0


#1

Gradually upgrading Ember application from 2.13 to latest version but going from 2.13 to 2.16 I am encountering an error that is difficult to figure. I am using Vagrant with virtualbox to run the application in a development environment.

Application works fine in version 2.13 but getting the error once I vagrant ssh into app at 2.16

The error is…

DEPRECATION: ember-cli-babel 5.x has been deprecated. Please upgrade to at least 
ember-cli-babel 6.6. Version 5.2.8 located: gt-ember-sso -> gt-ember-sso -> ember- 
countdown -> ember-cli-babel
DEPRECATION: ember-cli-babel 5.x has been deprecated. Please upgrade to at least 
ember-cli-babel 6.6. Version 5.2.8 located: gt-ember-sso -> ember-ajax -> ember-cli- 
babel
Unexpected token <<


Stack Trace and Error Report: 
/tmp/error.dump.c1be8c2e7a8d06967295116539d06e5c.log
An error occurred in the constructor for ember-resolver at 
/vagrant/node_modules/ember-resolver

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! gt-ember-sso@0.6.0 start-vm: `ember server --live-reload-port=9999 -- 
watcher polling`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the gt-ember-sso@0.6.0 start-vm script.
npm ERR! This is probably not a problem with npm. There is likely additional logging 
output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/vagrant/.npm/_logs/2018-05-17T21_13_35_797Z-debug.log
Connection to 127.0.0.1 closed.

I am using ember-reolver addon in the application the version of this addon is ^4.1.0


#2

Where is this token coming from? Perhaps there is a unresolved Git conflict chunk in one of the source files?


#3

Agree with @richard-nz, these sorts of errors (syntax errors with <<<,====, >>>>, etc) generally point to a git merge conflict to my eyes…


#4

Thank you this has been solved, the token was due to merge conflicts went through all errors (Visual Studio code made it easy) and corrected to get the app up to 2.18 thanks !