Ember.run.later in 1.8 beta doesn't work anymore in my app


#1

I’m testing an Ember application using the latest version of Ember.js 1.8 beta (5).

I noticed that some Ember.run.later functions don’t execute anymore (probably under certain circumstances). They simply aren’t executed. Replacing the statements with Ember.run.once makes them work again.

Now, I tried to create a simple test case outside my application but I couldn’t reproduce the behavior. So maybe it’s something in my application but I have no clue where to start searching.

Any idea about this?


#2

I tested in a couple of my ember-cli apps, and Ember.run.later does seem to be working properly, so it is most likely situational.

This would be a pretty huge deal, would love it if you could track down what was going on.


#3

I’ll dive deeper into this and let you know here. Thank you.


#4

If you do find an issue, please report it in the Ember repo so we can triage and get it fixed ASAP.


#5

The issue seems to have started with 1.8 beta 4. My app works fine with beta 3.

Ember 1.8.0-beta.4 (October, 5, 2014)

  • [BUGFIX] Enable setProperties to work on Object.create(null) objects.
  • [PERF] Update RSVP to 3.0.14 (faster instrumentation). [BUGFIX] Add SVG support for metal-views.
  • [BUGFIX] Allow camelCase attributes in DOM elements.
  • [BUGFIX] Update backburner to latest.

#6

Mystery solved

The culprit was an external library which I’m using in my application: date.js: http://www.datejs.com/

If I include the library after the Ember.js library Ember.run.later works again.

Maybe it’s a good opportunity to get rid of that library. :slight_smile: