EmberCli not creating Brocfile.js


#1

I did an upgrade of my project to Ember 2.0.0-beta.2. But it seems to be broken. So I went back to Ember 2.0.0-beta.1. Then my Bootstrap did not load anymore in vender.css. I tried to reinstall everything, no result. When I tried to create a new project, I am missing the Brocfile.js. I tried to create by hand, but I can’t get Bootstrap to include. Any suggestions? version: 1.13.1 node: 0.12.7 npm: 2.12.1


#2

Perhaps it would be useful to provide the errors that are outputted to the terminal.


#3

That’s the strange thing I don’t get any errors.


#4

Try nuking everything and starting anew:

$ rm -rf node_modules
$ npm cache clear
$ npm install
$ rm -rf bower_modules
$ bower cache clean
$ bower install
How about showing us the contents of your `package.json` and `bower.js` files?

#5

it is like ‘bower install’ is doing anything.

bower.json: { “name”: “examen”, “dependencies”: { “ember”: “2.0.0-beta.1”, “ember-data”: “1.13.4”, “ember-cli-shims”: “ember-cli/ember-cli-shims#0.0.3”, “ember-cli-test-loader”: “ember-cli-test-loader#0.1.3”, “ember-load-initializers”: “ember-cli/ember-load-initializers#0.1.5”, “ember-qunit”: “0.4.1”, “ember-qunit-notifications”: “0.0.7”, “bootstrap”: “~3.3.5”, “ember-addons.bs_for_ember”: “~0.7.0”, “select2”: “3.5.2”, “ember-cli-moment-shim”: “~0.2.0” }, “resolutions”: { “jquery”: “^2.1.4”, “ember-resolver”: “~0.1.18”, “loader.js”: “ember-cli/loader.js#3.2.0”, “qunit”: “~1.17.1” } }

package.json:

{ “name”: “examen”, “version”: “0.0.0”, “description”: “Small description for examen goes here”, “private”: true, “directories”: { “doc”: “doc”, “test”: “tests” }, “scripts”: { “start”: “ember server”, “build”: “ember build”, “test”: “ember test” }, “repository”: “”, “engines”: { “node”: “>= 0.10.0” }, “author”: “”, “license”: “MIT”, “devDependencies”: { “broccoli-asset-rev”: “^2.0.2”, “ember-cli”: “1.13.1”, “ember-cli-app-version”: “0.4.0”, “ember-cli-babel”: “^5.0.0”, “ember-cli-content-security-policy”: “^0.4.0”, “ember-cli-dependency-checker”: “^1.0.1”, “ember-cli-htmlbars”: “0.7.9”, “ember-cli-ic-ajax”: “0.2.1”, “ember-cli-inject-live-reload”: “^1.3.0”, “ember-cli-qunit”: “0.3.15”, “ember-cli-uglify”: “^1.0.1”, “ember-data”: “1.13.4”, “ember-select-2”: “^1.3.0” }, “dependencies”: { “ember-moment”: “^1.2.1”, “ember-disable-proxy-controllers”: “^1.0.0”, “ember-export-application-global”: “^1.0.2” } }


#6

Bower install gives that: bower ember-resolver extra-resolution Unnecessary resolution: ember-resolver#~0.1.18 bower loader.js extra-resolution Unnecessary resolution: loader.js#ember-cli/loader.js#3.2.0 bower qunit extra-resolution Unnecessary resolution: qunit#~1.17.1


Why is it so difficult to add bootstrap?
#7

Try created a new dummy project, fire it up and ensure it runs alright, and then compare the contents with your project.


#8

I just created a new project: ember new project. Again there is no Brocfile.js created. The project looks fine.


#9

It’s been removed in favor of ember-cli-build.js


#10

thx. That did it!! It is a bit frustrating, everything is changing very fast!


#11

yeah. i feel the pain too! :cry: