How to prevent ember-cli's proxy to cache the requests [solved]


#1

Hi,

I’m using ember-cli with ‘–proxy’. Everything is fine but when I noticed that the proxy caches the query responses (304). It’s ok until I started to save the data into the db:

$ ember serve
version: 0.1.9
Proxying to http://localhost:4000
Livereload server on port 35729
Serving on http://0.0.0.0:4200/
...
GET /api/1/publication?_id=51000283&_limit=1 304 10.144 ms - -
POST /api/1/publication 200 29.754 ms - 743
GET /api/1/publication?_id=51000283&_limit=1 304 7.833 ms - -

In this example, the old data is send back. Is there a way to disable the caching ?

Thank you


#2

Nevermind. It’s a silly question, the caching was from the proxied server. :sweat_smile:

sorry