Naming mixin which is used as service (api call)


Generally my naming convention for mixin is feature_mixin.js

However, for some classes (which are used to make api service calls), i have the naming as feature_service.js (Even though I use the above as Mixin)

Now since, Ember has a separate Service class concept, Is there a better naming convention for such kind of mixins ?


Why not to use those ‘service’ mixins as actual Ember Service?