Node V5 / NPM v3.3.9 Errors


Updated to Node v5 and trying to run an app produces errors:

ember s
Future versions of Ember CLI will not support v5.0.0. Please update to Node 0.12 or io.js.
version: 1.13.8
Livereload server on http://localhost:49152
Serving on http://localhost:4200/
ENOENT: no such file or directory, stat '/Users/john/Devel/ember/mindstorm/tmp/concat_with_maps-input_base_path-e8hD9TJU.tmp/0/bower_components/ember-resolver/dist/modules/ember-resolver.js'
Error: ENOENT: no such file or directory, stat '/Users/john/Devel/ember/mindstorm/tmp/concat_with_maps-input_base_path-e8hD9TJU.tmp/0/bower_components/ember-resolver/dist/modules/ember-resolver.js'
at Error (native)
at Object.fs.statSync (fs.js:892:18)
at ConcatWithMaps.keyForFile (/Users/john/Devel/ember/mindstorm/node_modules/broccoli-sourcemap-concat/node_modules/broccoli-caching-writer/index.js:91:55)
at (native)
at ConcatWithMaps.CachingWriter._conditionalBuild (/Users/john/Devel/ember/mindstorm/node_modules/broccoli-sourcemap-concat/node_modules/broccoli-caching-writer/index.js:107:61)
at /Users/john/Devel/ember/mindstorm/node_modules/broccoli-sourcemap-concat/node_modules/broccoli-plugin/read_compat.js:61:34
at lib$rsvp$$internal$$tryCatch (/Users/john/Devel/ember/mindstorm/node_modules/rsvp/dist/rsvp.js:493:16)
at lib$rsvp$$internal$$invokeCallback (/Users/john/Devel/ember/mindstorm/node_modules/rsvp/dist/rsvp.js:505:17)
at lib$rsvp$$internal$$publish (/Users/john/Devel/ember/mindstorm/node_modules/rsvp/dist/rsvp.js:476:11)
at lib$rsvp$asap$$flush (/Users/john/Devel/ember/mindstorm/node_modules/rsvp/dist/rsvp.js:1198:9)

I have no idea where to begin to fix this…


Well, I noticed that the package.json was missing “ember-resolver”: “^2.0.3” (probably from me trying to keep up with changes in ember-cli that haven’t been released, but that’s another issue…). So I added ember-resolver back to the package.json and did an npm install. Now it’s even worse - pages and pages of build errors:

So, note to early adopters - don’t upgrade node!


I wonder why EmberJS will not support the latest version of Node? As I know, io.js is now merged into the node.


That “future version of Ember CLI will not support xxx” has been fixed in a future, unreleased version of Ember CLI. One we’ve been waiting for, for getting on 3 months now. That popped up when Node and io.js merged and its version jumped from versions < 1.0 to > 4.0.


Another data point. I created a brand new Ember app (‘ember new testing’) and that installed everything just fine. So I’m guessing it’s whatever fiddly bits have been updated and are in the master branch of Ember CLI’s package.json that are the cause of the problem. Unfortunately, there’s so many things that changed, I wouldn’t know where to begin!


Until everything is up to date, I was able to back out my Node / npm upgrade. Since I’m using Homebrew, I was able to downgrade node using:

  brew switch node 4.2.1

But that doesn’t change the version of NPM, do to get the previous version I did:

npm install -g npm@latest-2


Not a solution for everyone but installing ember-cli from master will resolve this issue.


Better remove the Node you installed via homebrew and install it via nvm

Node versions installed via nvm always come bundled with the recommended npm