Package.json vs Bower.json


Is there a best practice for components should be listed in package.json vs which should be in my bower.json

I’ve got a few elements in both - like ember data, and when I upgraded to 1.13.6 the files got out of sync.

Do I need this duplication or can I eliminate some of the references?

In my package.json

"devDependencies": {
    "active-model-adapter": "1.13.6",
    "broccoli-asset-rev": "^2.1.2",
    "broccoli-concat": "0.0.13",
    "broccoli-funnel": "^0.2.8",
    "ember-cli": "1.13.8",
    "ember-cli-app-version": "0.5.0",
    "ember-cli-babel": "^5.1.3",
    "ember-cli-content-security-policy": "0.4.0",
    "ember-cli-dependency-checker": "^1.0.0",
    "ember-cli-htmlbars": "0.7.9",
    "ember-cli-htmlbars-inline-precompile": "^0.2.0",
    "ember-cli-ic-ajax": "0.2.1",
    "ember-cli-inject-live-reload": "^1.3.0",
    "ember-cli-qunit": "1.0.0",
    "ember-cli-release": "0.2.5",
    "ember-cli-uglify": "^1.0.1",
    "ember-data": "1.13.9",
    "ember-disable-proxy-controllers": "^1.0.1",
    "ember-export-application-global": "^1.0.2",
    "ember-watson": "^0.6.2"

and in my bower .json

 "dependencies": {
    "ember": "1.13.8",
    "ember-cli-shims": "ember-cli/ember-cli-shims#0.0.3",
    "ember-cli-test-loader": "ember-cli-test-loader#0.1.3",
    "ember-data": "1.13.9",
    "ember-load-initializers": "ember-cli/ember-load-initializers#0.1.5",
    "ember-qunit": "0.4.1",
    "ember-qunit-notifications": "0.0.7",
    "ember-resolver": "~0.1.18",
    "loader.js": "ember-cli/loader.js#3.2.0",
    "qunit": "~1.17.1",
    "moment": "~2.10.3",
    "bootstrap": "~3.3.5",
    "autosize": "~3.0.8",
    "flot": "~0.8.3",
    "seedrandom": "~2.4.2",
    "jquery-mobile": "~1.4.5",
    "jquery.sparkline": ""

Thanks for any insight


You could always just rename both files and run ember init to regenerate the files. Then npm/bower install what you’re missing.


Some packages are installed with npm, some with bower. The only duplicate i see is for Ember-Data. If you look at the readme for that under bower_components you’ll see that that package is a shim.(I don’t know why, however.)


What if you want to use a specific ember + ember-data version? The last stable release for instance? Are you left to your own devices, or can ember-cli help you out?