Addepar Ember table won't serve npm


#1

I’m can’t get the Addepar table to work locally. Everytime I get the following error:
Cannot find module 'C:\Windows\System32\addepar-table\bower_components\ember\emb er-template-compiler’ Error: Cannot find module 'C:\Windows\System32\addepar-table\bower_components\em ber\ember-template-compiler’ _ at Function.Module.resolveFilename (module.js:469:15) _ at Function.Module.load (module.js:417:25) _ at Module.require (module.js:497:17)_ _ at require (internal/module.js:20:19)_ _ at Class.htmlbarsOptions (C:\Windows\System32\addepar-table\node_modules\emb_ er-cli-to-wp-theme\node_modules\ember-cli-htmlbars\ember-addon-main.js:72:25) _ at Object.toTree (C:\Windows\System32\addepar-table\node_modules\ember-cli-t_ o-wp-theme\node_modules\ember-cli-htmlbars\ember-addon-main.js:31:43) _ at C:\Windows\System32\addepar-table\node_modules\ember-cli-preprocess-regis_ try\preprocessors.js:180:26 _ at Array.forEach (native)_ _ at processPlugins (C:\Windows\System32\addepar-table\node_modules\ember-cli-_ preprocess-registry\preprocessors.js:178:11) _ at module.exports.preprocessTemplates (C:\Windows\System32\addepar-table\nod_ e_modules\ember-cli-preprocess-registry\preprocessors.js:161:10)

  • The Addepar table is at version 0.9.2
  • Ember-cli at version 5.3.0 You help will be greatly appreciated.

#2

Perhaps it is just that it is in the C:\Windows\System32\ folder. Does this also happen when you install in lets say C:\App ?


#3

Also it seems to be an abandoned project??


#4

Too bad, I had some high hopes on the Addepar table. All my other projects run without errors locally, maybe it’s because the project hasn’t been updated in a while.

I will look for an alternative maybe React or Angular to achieve the same functionality.


#5

It is no problem for Ember. Alternatives https://www.emberaddons.com/?query=table

Edit: And https://www.npmjs.com/package/ember-cli-ember-table


#6

Also the it seems in your error that you try to load addepar-table not ember-table but the NPM name is ember-table.


#7

Thank you for your suggestions, I will try each of the alternatives, and hopefully I will find one that works for me.

As for the addepar-table/ember-table loading error, I initially created addepar-table folder and installed ember-table in the folder and tried to serve it and ended up with tons of errors such as: Deprecated graceful-fs module, git is installed in path and update minimatch version etc.

I also tried serving ember-table when it’s on its own path and still got a bunch of errors. I didn’t know that installing ember-table locally was difficult.