Can't get application.hbs, or anything else, to render in rails app


#1

I’m trying to get a new ember app running in an existing rails app. When I render the root its just a blank page, but the console is showing:

 DEBUG: ------------------------------- application.js:12147
 DEBUG: Ember.VERSION : 1.0.0-rc.3 application.js:12147
 DEBUG: Handlebars.VERSION : 1.0.0-rc.3 application.js:12147
 DEBUG: jQuery.VERSION : 1.9.1 application.js:12147
 DEBUG: ------------------------------- application.js:12147
 DEPRECATION: register("store", "main") is now deprecated in-favour of register("store:main");
    at Object.Container.register (http://localhost:3000/assets/application.js:18819:17)
    at Application.initializer.initialize (http://localhost:3000/assets/application.js:46015:19)
    at http://localhost:3000/assets/application.js:39234:7
    at visit (http://localhost:3000/assets/application.js:38434:3)
    at DAG.topsort (http://localhost:3000/assets/application.js:38488:7)
    at Ember.Application.Ember.Namespace.extend.runInitializers (http://localhost:3000/assets/application.js:39231:11)
    at Ember.Application.Ember.Namespace.extend._initialize (http://localhost:3000/assets/application.js:39188:10)
    at http://localhost:3000/assets/application.js:16309:19
    at Object.Ember.handleErrors (http://localhost:3000/assets/application.js:12209:17) 

My application.hbs has the following:

<h1>MOBILE MANAGER</h1>
{{outlet}}

And my Mdn(App).js has the following:

//= require_self
//= require_tree .
//= require_tree ./models
//= require_tree ./controllers
//= require_tree ./views
//= require_tree ./helpers
//= require_tree ./templates
//= require_tree ./routes

window.Mdm = Ember.Application.create();

So Ember is clearly loaded but I cant get any templates to render. Thanks for your help!


#2

Fixed it. Directory order issue.