Cannot find module './server' from path/

i am trying to ember serve one app but it is throwing above error. I tried re-installing npm install.

No Success. Please help.


Hi @soniya_kapoor, welcome! Could you describe what you tried in a little more detail?

Typically you would do something like the following:

  1. install ember cli globally npm install -g ember-cli(double check your install with ember --version)
  2. start a new ember app or clone an existing one
  3. (in the app root directory) run npm install or yarn install to download the dependencies
  4. run ember serve or the shorthand ember s


i tried following all these steps. I cloned the project on my local and no trying to run it. ./server is the folder where all the content is. that i cloned from content branch.

please suggest what should try more to rule this out. i want to work on version upgradation of this app.


Hmmm I think we still may need more details about the files you have here. An ember project should look something like this:


Is that what your directory looks like? What command did you use to try and run this? And what does your package.json look like? And also is there a bower.json file?

package.json { “name”: “@cibc/Project1”, “version”: “1.1.4”, “description”: “The default blueprint for ember-cli addons.”, “publishConfig”: { “registry”: “” }, “keywords”: [ “ember-addon” ], “license”: “MIT”, “author”: “”, “directories”: { “doc”: “doc”, “test”: “tests” }, “repository”: { “type”: “git”, “url”: “Path” }, “scripts”: { “build”: “ember build”, “lint:js”: “eslint ./.js addon addon-test-support app config lib server test-support tests", “start”: “ember serve”, “test”: “ember try:each” }, “dependencies”: { “@cibc/context-service”: “^2.18.0”, “@cibc/cp-validation-kit”: “^2.18.4”, “@cibc/datekit”: “^2.18.2”, “@cibc/exceptionkit”: “^2.18.9”, “@cibc/otvc-service”: “2.18.5”, “@cibc/resourcekit”: “^2.18.0”, “@cibc/route-state-service”: “^2.18.0”, “@cibc/storage-service”: “^2.18.0”, “@cibc/uikit”: “^2.18.30”, “ember-cli-babel”: “^6.6.0”, “ember-cli-htmlbars”: “^2.0.1”, “ember-cli-sass”: “^7.1.7”, “ember-cp-validations”: “^3.3.1”, “ember-data”: “^2.18.0”, “moment”: “^2.18.1” }, “devDependencies”: { “@cibc/analyticskit”: “^2.18.0”, “@cibc/data-format-kit”: “1.0.0”, “@cibc/ember-ci-docker”: “^2.18.1”, “@cibc/testem-docker”: “^0.1.3”, “broccoli-asset-rev”: “^2.4.5”, “ember-ajax”: “^3.0.0”, “ember-cli”: “~2.18.2”, “ember-cli-dependency-checker”: “^2.0.0”, “ember-cli-eslint”: “^4.2.1”, “ember-cli-htmlbars-inline-precompile”: “^1.0.0”, “ember-cli-inject-live-reload”: “^1.4.1”, “ember-cli-mirage”: “^0.4.7”, “ember-cli-qunit”: “^4.1.1”, “ember-cli-shims”: “^1.2.0”, “ember-cli-sri”: “^2.1.0”, “ember-cli-uglify”: “^2.0.0”, “ember-data”: “^2.18.2”, “ember-disable-prototype-extensions”: “^1.1.2”, “ember-engines”: “^0.5.18”, “ember-exam”: “^1.0.0”, “ember-export-application-global”: “^2.0.0”, “ember-load-initializers”: “^1.0.0”, “ember-resolver”: “^4.0.0”, “ember-sinon”: “^0.7.0”, “ember-source”: “~2.18.0”, “eslint-plugin-ember”: “^5.2.0”, “eslint-plugin-node”: “^5.2.1”, “loader.js”: “^4.2.3” }, “engines”: { “node”: "^4.5 || 6. || >= 7.*” }, “ember-addon”: { “configPath”: “tests/dummy/config”, “paths”: [ “lib/forms-kit” ] } }

i m using ember s to run the project

ok so you have a bower file, did you also install bower globally (npm install -g bower) and run bower install?

Also I see there is a server directory in your project, this is kind of a long shot but what happens if you rename that to something else like app_server?

And what happens if you run node_modules/.bin/ember serve instead of just ember s?

Now i came to know it was and engine and is dependent on some other project. so now cloning different one. I hope it will work. thanks for your help so far

Ah yes that makes more sense :sweat_smile: glad you got it figured out! Definitely let us know if you get stuck again

Thanks for your help