Can't get Qunit tests to run, only jshint


#1

I’m in the process of upgrading an Ember app that previously hadn’t been touched in 8 months, and after I finally got it working again and wrote some tests on it, realized none of the Qunit tests are running when I run ‘ember test’ - only jshint.

My dependencies are all up to date, and I looked at another Ember app I work on to be sure that the naming conventions, file structure, and files such as testem.json and resolver.js are following similar conventions. Nothing seems out of the ordinary. I had a co-worker look at it as well, and he also could not see any outstanding errors or meaningful differences.

Everything I’ve Googled has come up short - the solutions others have had haven’t worked for me. Any ideas?


#2

Do your tests end with -test.js in the filename?


#3

Yup! Every single one of them. I noticed that was someone else’s issue but sadly not mine.


#4

Confirm you are using the latest ember-cli-qunit and put a breakpoint in https://github.com/ember-cli/ember-cli-test-loader/blob/master/test-loader.js#L20 to see if the test modules are found and used.


#5

That was it! A typo in my package.json, was missing a number in the version number of ember-cli-qunit. Somehow I kept missing that every time I looked but now my tests are running. Huzzah! Thanks again.