"Could not find module `htmlbars-inline-precompile`" on component integration tests in 1.13

I’m running ember-cli 1.13.1 and Ember 1.13.5, trying to get my auto-generated component integration tests to pass. My tests are currently failing because "Could not find module htmlbars-inline-precompile" (which is imported at the top of the page for each test). I’m running ember-cli-htmlbars 0.7.9 and ember-cli-htmlbars-inline-precompile 0.2.0. Anyone else run into this? Any ideas?

Yeah, just had this problem yesterday. You can fix it by running this in your console: ember install ember-cli-htmlbars-inline-precompile. (Assuming you’re using Ember CLI.)

EDIT: Ah, just noticed that you already have it installed. Not sure what else could be causing the problem.

1 Like

Dang! Oh well. Yeah I definitely have ember-cli-htmlbars-inline-precompile installed… I’ve definitely nombom’d and reinstalled several times. Checked version numbers. No idea what the problem is. The only tests I have failing right now are these auto-generated component integration tests due to this error and it’s driving me crazy!

I ended up deleting all the auto-generated component integration tests because I was never able to figure out the source of this failure. Curious if anyone else experiences this though - I don’t want to be deleting tests, it just feels wrong.

I just ran into this problem. I believe the problem is that you need to update your version of ember-cli-babel to be compatible with ember-cli-htmlbars-inline-precompile.

2 Likes

Any idea of what versions those would be?

This is from my package.json. The inline precompile works just fine

  "devDependencies": {
    "broccoli-asset-rev": "^2.0.2",
    "broccoli-caching-writer": "^2.0.1",
    "commonmark": "^0.22.0",
    "ember-cli": "1.13.8",
    "ember-cli-app-version": "^1.0.0",
    "ember-cli-auto-register-helpers": "~1.0.2",
    "ember-cli-content-security-policy": "0.4.0",
    "ember-cli-dependency-checker": "^1.0.0",
    "ember-cli-htmlbars-inline-precompile": "^0.3.0",
    "ember-cli-ic-ajax": "0.2.1",
    "ember-cli-inject-live-reload": "^1.3.0",
    "ember-cli-qunit": "1.0.1",
    "ember-cli-release": "0.2.6",
    "ember-cli-sass": "4.2.0",
    "ember-cli-uglify": "^1.0.1",
    "ember-data": "1.13.11",
    "ember-data-fixture-adapter": "1.13.0",
    "ember-disable-prototype-extensions": "^1.0.0",
    "ember-disable-proxy-controllers": "^1.0.0",
    "ember-export-application-global": "^1.0.2",
    "ember-try": "0.0.8"
  },

Is there any updates on this issues?? I’m facing the same problem. My Integration test for a component fails with the error Could not find module htmlbars-inline-precompile.

It’s been a while, but I believe once I bumped the version of Ember I was using, it worked fine. I would check and make sure that you’re using all the most recent versions of everything.

Even after updating me ember version, the error persists… CLI fails to bundle the package… But I don’t know why…

Cutting the package “ember-cli-htmlbars-inline-precompile” from ‘devDependencies’ and placing into ‘dependencies’ section of package.json worked for me.