Disable ember-cli hinting


#1

Each time I have to reload the page, the JSHinter checks all my code and tests.

This is great, but it terribly slowing down my reloads. See:

Build successful - 20656ms.

Slowest Trees | Total
-------------------------------±--------------- ES3SafeFilter | 3540ms
TreeMerger | 2825ms
JSHint - App | 2730ms
JSHint - Tests | 2541ms

I was wondering how can I disable the JSHint run in the ember cli? I already have JShint configured to highlight things in Sublime Text, I don’t need it in the cli as well (well, I can’t affort to wait 20 seconds for each reload…).


#2

Hi! Which version of Ember CLI are you using? Since 0.1.0 (or so) it got waaaay faster. On my old iMac it went from ~30 secs to ~2secs.

You should make sure to be on the newest: https://github.com/stefanpenner/ember-cli/releases. But not sure how to disable jshint, sorry.


#3

Hi,

I’m on 0.1.2. It’s not necessary Ember’s fault, my Samsung Series 5 with AMD A6 is crawling on Ubuntu…


#4
// in your Brocfilejs pass an object with `hinting: false` into EmberApp
var app = new EmberApp({
  hinting: false
});

#5

@jasonmit thank you! That seems to work better. I am not at 11second reload time, which is a huge improvement.

Are these options for all environments? Is there any way I can disable some options just for development and testing?