Ember array acting wierd on insertAt (and replace)

hi Guys,

since updating to ember 3.x i have alot of errors like method.apply is not a function. it’s happening within array actions like insertAt or replace. an example is below. I’ve tried to reproduce on ember-twiddle, but i cannot with simple arrays. i made a screenshot of my array and the thing i’m doing. i’m simply trying to insert to position 0, the item is already there, but got the error.

does anyone has an idea why it’s happening? it worked again with ember 2.x the error is at sendEven in ember-metal.


The exception is happening here.

If you break into the debugger at the exception, you could inspect the value of the local variable actions and it might shed light on what is going on.

thanks. i know where the error is, but i cannot find out why it’s failing …

interesting, if i do a deep copy of the array, and do the same actions, it’s working. cannot find out why (yet)

This may get more attention from people who know the internals well if you also file an issue on github.

ok, thanks for the suggestion