Ember + chrome bug, or what?


#1

I found some weird bug/condition that is almost impossible to goggle so I’ve dropped by here, looks like a good place to ask. I’m following a great tutorial of ember-cli at http://ember.vicramon.com/

I didn’t set it up exactly like the tutorial, I chose to go with a separate ember front end and rails backend.

Just when the tutorial was getting good, I had to create a page to display data, here’s the hbs (the tutorial uses emblem, but I verified the problem exists in each)

<article id="leads">
  <h1>Leads</h1>
  <ul>
    {{#each lead in controller}}
      <li>{{lead.firstName}}</li>
    {{/each}}
  </ul>
</article>

So nothing displayed. So I checked the data in the ember inspector. Its all there. I checked the dom elements, and the data is all there. Its just not showing up on the page, not even the <h1>Leads </h1> part.

Ok, so I figured the tutorial came with some questionable CSS. So I nuked the CSS. The styling went away, but the stuff was still missing.

I’ve viewing this on my chromebook. So I jumped over to my mac and still no data on the screen. Then I thought I’d give firefox a try (I had only been using chrome). The data appears! Same with safari!

Ok, so problem with all chrome browsers. In desperation I changed the id=“leads” to id=“leeds”, and it fixed the problem.

I tried a static html page and of course it worked. So its got something to do with ember.js and chrome and possibly the code in this tutorial. I could readily accept I’m doing something really stupid, I’m used to it, but only happening in chrome? Maybe I need to start deleting chrome extensions common to both my chromebook and mac, maybe that could explain it

The author put up a demo app here http://embercrm.herokuapp.com/

I don’t see anything except the orange header in chrome or safari, but I see a list in firefox and opera. (chrome and safari both use webkit? for rendering?)


#2

I can confirm your bug - please report it over at the [GitHub Repository] (https://github.com/emberjs/ember.js/issues)

EDIT:

I just visited the Heroku App with different browsers on my dev-machine (win 8.1) and here are the results:

Chrome                   | Version 41.0.2272.101 m    | --> NO LIST
Firefox                  | Version 35.0.1             | --> LIST
Internet Expolorer       | Version  11.0.9600.17690   | --> LIST
Opera                    | Version 28.0               | --> LIST
Vivaldi                  | Version 1.0.83.38          | --> LIST

#3

I posted this to github


#4

Its the chrome AdBlock extension. I did mention I would look at extensions, so do I score points for that?