Error in nested templating


#1

EDIT: RESOLVED SOMEHOW

After making this post I thought “Hey, maybe ember generate can create proper nested routes” so I ran ‘ember generate route admin.show’ and well, ember can’t generate nested routes. Then I deleted the files that the command had made (funky files like admin.show.hbs in /templates) and my program worked!

I should probably find a new profession

P.S. I’m pretty sure it wasn’t a case of saving/reloading the project, because I did that at least a million times prior to making this post. I guess we all need a little magic in our lives.


Code here: https://github.com/bjones6/ember-cli-templating-error

I have a nested route like so:

    this.route("admin", function(){
        this.route("show");
    });

And a template directory like nyah:

    template/
        admin/
            show.hbs
        admin.hbs

But when I {{#link-to "admin.show"}} in the admin route the template does not render in the {{outlet}}.

I checked the Ember debug toolbar and it seemed like Ember was autogenerating a template because a template was not found.

All documentation I can find is telling me everything was in the right place, and I've tried every directory combination I can think of.

What does ember-cli want from me??

Kind of frustrating right meow.

Thanks for reading my question.