Error with Ember 1.10.0-beta.1 using Ember CLI

I created a new ember-cli 0.1.4 application and I’m getting this error in the console.

Uncaught Error: Assertion Failed: template must be a function. Did you mean to call Ember.Handlebars.compile("...") or specify templateName instead? 

This is my package.json

"devDependencies": {
    "body-parser": "^1.2.0",
    "broccoli-asset-rev": "0.3.0",
    "ember-cli-htmlbars": "^0.5.1",
    "ember-cli": "0.1.4",
    "ember-cli-content-security-policy": "0.3.0",
    "ember-cli-ic-ajax": "0.1.1",
    "ember-cli-inject-live-reload": "^1.3.0",
    "ember-cli-qunit": "0.1.2",
    "ember-data": "1.0.0-beta.12",
    "ember-export-application-global": "^1.0.0",
    "express": "^4.8.5",
    "glob": "^4.0.5"

This is my bower.son

  "name": "thebuild",
  "dependencies": {
    "handlebars": "~1.3.0",
    "jquery": "^2.1.1",
    "ember": "1.10.0-beta.1",
    "ember-data": "1.0.0-beta.12",
    "ember-resolver": "~0.1.7",
    "loader.js": "stefanpenner/loader.js#1.0.1",
    "ember-cli-shims": "stefanpenner/ember-cli-shims#0.0.3",
    "ember-cli-test-loader": "rwjblue/ember-cli-test-loader#0.0.4",
    "ember-load-initializers": "stefanpenner/ember-load-initializers#0.0.2",
    "ember-qunit": "0.1.8",
    "ember-qunit-notifications": "0.0.4",
    "qunit": "~1.15.0"
    "ignore": [],
    "resolutions": {
        "ember-data": "1.0.0-beta.12",
        "ember": "1.10.0-beta.1",
        "jquery": "2.1.1"

Any help comes with thanks and welcome.

Did you delete bower_components and node_modules then re-install them?

Could it be related to this bug report?

1 Like

Try bumping the versions of a few dependancies, namely handlebars. I just read this release doc


I think that is the problem - but ember-cli tells you that you must use canary to enable flag feature (beta is out)