Failed to parse SourceMap: assets/vendor.map


#1

Lately I’m getting:

Failed to parse SourceMap: http://localhost:4200/assets/vendor.map

In the chrome console and I don’t what could be the cause or where to start digging. Does anyone have had the same error with an Ember app?

I’m using Ember 2.4.5


#3

@Henry could you tell me if you found a solution?


#4

Not yet. If I found something I’ll post it here :slight_smile:


#5

I have this same issue. Running the same version of Ember as you are. - Not sure the cause, but turning off Chrome’s “Enable JavaScript Source Maps” setting stops the error (not a fix)


#6

Can you list out the addons you are using?


#7

The last two I’ve installed before the problem started are broccoli-serviceworker and ember-test-selectors (until them I haven’t had any problem). Do you think the error can be related with them?


Failed to parse sourceMap
#8

I’m starting to see this too, but only on Chrome (Version 51.0.2704.79 (64-bit)). FireFox shows no errors.

I thought maybe I introduced some error, so I reverted to an older version of my code from about 1.5 weeks ago, and I’m still seeing this error.

Also, my coworker is not seeing the issue, but her Chrome is on version 50.x, not 51.x.

So maybe a Chrome issue?


#9

It is a chrome bug. The bug is reported in this thread and fixed in this commit

The bugfix is still not landed in chrome (51.0.2704.84). In Chrome Canary its fixed