Fingerprint issue with ckeditor


#1

I have addon ckeditor in my project to edit online documents, while making “production” build I excluded ckeditor from fingerprinting by adding following in ember-cli-build.js file

fingerprint: { exclude: [‘ckeditor’], ignore: [‘ckeditor’] }

While building ckeditor (addon) is excluded from fingerprinting process but inside the code of this addon where ever config.js is writter is replaced with something like ‘config-0d68c37b8dc29e4e866c6bda8d777bd1.js’

This file name is of config file of ember app lying in dist/config-0d68c37b8dc29e4e866c6bda8d777bd1.js

but assets/ckeditor/config.js name is not changed

Please help me to truly exclude ckeditor from ‘fingerprinting’ such that content of its files is NOT altered at all

Regards

Dn


#2

I searched a lot on net to resolve the issue but nothing worked for my case

console error

managedocs:1 Refused to execute script from ‘myproject/assets/ckeditor/config-0d68c37b8dc29e4e866c6bda8d777bd1.js?t=I3I8’ because its MIME type (‘text/html’) is not executable, and strict MIME type checking is enabled