Fresh install of 3.5.0 live reload error


#1

Getting this error on fresh install and viewing welcome page:

ember -v:
ember-cli: 3.5.0
node: 8.12.0
os: darwin x64

Firefox can’t establish a connection to the server at ws://localhost:4200/_lr/livereload. [livereload.js:106](http://localhost:4200/_lr/livereload.js?port=4200&host=localhost&path=_lr/livereload:formatted)

Firefox can’t establish a connection to the server at ws://localhost:4200/_lr/livereload. [livereload.js:106](http://localhost:4200/_lr/livereload.js?port=4200&host=localhost&path=_lr/livereload:formatted)

DEBUG: -------------------------------
DEBUG: Ember : 3.5.0 
DEBUG: Ember Data : 3.5.0
DEBUG: jQuery : 3.3.1
DEBUG: -------------------------------

package.json:

{
  "name": "raggamuffin",
  "version": "0.0.0",
  "private": true,
  "description": "Small description for raggamuffin goes here",
  "repository": "",
  "license": "MIT",
  "author": "",
  "directories": {
    "doc": "doc",
    "test": "tests"
  },
  "scripts": {
    "build": "ember build",
    "lint:hbs": "ember-template-lint .",
    "lint:js": "eslint .",
    "start": "ember serve",
    "test": "ember test"
  },
  "devDependencies": {
    "@ember/jquery": "^0.5.2",
    "@ember/optional-features": "^0.6.3",
    "broccoli-asset-rev": "^2.7.0",
    "ember-ajax": "^3.1.0",
    "ember-cli": "~3.5.0",
    "ember-cli-app-version": "^3.2.0",
    "ember-cli-babel": "^6.16.0",
    "ember-cli-dependency-checker": "^3.0.0",
    "ember-cli-eslint": "^4.2.3",
    "ember-cli-htmlbars": "^3.0.0",
    "ember-cli-htmlbars-inline-precompile": "^1.0.3",
    "ember-cli-inject-live-reload": "^1.8.2",
    "ember-cli-sri": "^2.1.1",
    "ember-cli-template-lint": "^1.0.0-beta.1",
    "ember-cli-uglify": "^2.1.0",
    "ember-data": "~3.5.0",
    "ember-export-application-global": "^2.0.0",
    "ember-load-initializers": "^1.1.0",
    "ember-maybe-import-regenerator": "^0.1.6",
    "ember-qunit": "^3.4.1",
    "ember-resolver": "^5.0.1",
    "ember-source": "~3.5.0",
    "ember-welcome-page": "^3.2.0",
    "eslint-plugin-ember": "^5.2.0",
    "loader.js": "^4.7.0",
    "qunit-dom": "^0.8.0"
  },
  "engines": {
    "node": "6.* || 8.* || >= 10.*"
  }
}

#2

Yep, this was due to a mistake I made prior to release (merged a PR into the wrong branch :crying_cat_face: ) .

See the following for details:


#3

Ha ha. Ok thanks, I’ll get a fresh copy! :slight_smile: