I can't create a new project?


#1

version: 2.3.0-beta.2 node: 4.2.6 npm: 2.14.10 os: win32 x64

I really want to work with emberjs but when i run the command ember new t-app on the Node.js command prompt it hangs at Installing packages for tooling via npm... when i run it in --verbose mode it keeps showing npm commands but it never ends or i just don’t have the patience to wait for more than 20 minutes for a new project


#2

It’s unfortunately a problem of npm. It takes long in my computer… but never 20 minutes! How good is your internet connection? Does it abort after a certain amount of time?

I would wait… subsequent npm installs will go much faster, and Ember is worth it :slight_smile:


#3

this is frustrating my connection is 10MB download i reinstalled ember but now i get an error Cannot find module ember-cli-version-checker when i run ember -v


#4

I wish I could help, but I don’t know how :frowning: Ember CLI is unfortunately too bulky at the moment – but I’ve never seen anything as extreme as your case.


#5

I had the same problem. I tried creating a new app using ember new ... multiple times and each time it always hung on: Installing packages for tooling via npm…

Since not many users seemed to have this issue, I concluded its related to my node/npm setup. (I had recently been switching between multiple, older node versions using nvm. nvm cleanly uses separate lib/node_modules directories, but since I was stuck I decided to just try cleaning things up). So here’s what I did.

  • I wiped out my ~/.npm and ~/.npm-gyp (.nvm too since I was use nvm)
  • Did a fresh install of node 5.5.0 (basically to make sure /opt/lib/node_modules/ are clean. [I download node and keep it in /opt/node])
  • Installed bower before installing ember.

Doing the above worked, although I’m not sure which step actually solved it.

This solution is pretty vague. I had already spent enough time on this, so I didn’t spend time pinpointing which step actually fixed it. Hope your problem gets fixed too.


#6

@kayo @emberigniter Thanks for your help i may try this


#7

I just came across this: https://github.com/mixu/npm_lazy , which might help speed up subsequent installs


#8

When creating a new app (ember new my-app) hangs , I do the following:

ember new --skip-npm --skip-bower my-app
cd my-app
npm install
bower install

This allows me to proceed with developing my app. I’ve used ember for just a month so I don’t know if its ok to do it this way.

For some reason doing ember new my-app hangs a lot on my machine. To try and see whats happening, I used the verbose flag (ember new -v my-app) which for a while spits out a lot of logs (I think mostly related to npm). After around 2 minutes or less, the logs stop but the shell doesn’t return and it looks like its just waiting for something which never happens. I’ve waited for an hour but nothing happens. So it needs to be terminated with a ^C. That’s why the above workaround.

$ ember --version
version: 2.3.0
node: 5.5.0
os: linux x64