Install issues with emberfire

I’m just starting to have a play with EmberJS and Firebase, and I’m trying to follow along with the quickstart here:

When I use the command ember install emberfire@next in my app directory I get the following output:

npm: Installed emberfire@next
installing emberfire
The `ember generate <entity-name>` command requires an entity name to be specified. For more details, use `ember help`.

I tried breaking the install down into two parts as per this post How to `ember install` for a package that is npm linked? [resolved]

npm install —save emberfire
ember generate emberfire

But the last command resulted in this errror

The `ember generate <entity-name>` command requires an entity name to be specified. For more details, use `ember help`.

However when I used the command ember generate emberfire test it seemed to work and gave this:

installing emberfire
  create app/adapters/application.js
  install package firebase
  install addon ember-auto-import
npm: Installed ember-auto-import
Installed addon package.
npm: Installed firebase@^5.1.0

To be honest, I don’t really know what I’m doing - why did the initial command not work and what is the @next bit all about?

I just found this thread - seems to be exactly the same issue but I’m not sure how I can get it working!

I’m not sure about the first error you saw when installing emberfire with ember install. It sounds like a bug.

This syntax is shorthand for the beta version of a package. You can explore what it evaluates to for a given package using yarn info <packagename> or npm view <packagename>. The first couple of lines from yarn info emberfire show that @next resolves to 3.0.0-rc.3:

yarn info v1.17.3
{ name:
   'The officially supported Ember binding for Firebase',
   { latest:
      '3.0.0-rc.3' },

@efx thanks for the info, I posted to that thread over on the emberfire issues, someone said that it was a bug and I should downgrade to 3.10 but that didn’t work, neither did downgrading to ember-cli 3.8.4! I ended up discovering that ember install emberfire@2.0.10 worked without an issue, but subsequently I found that I needed to downgrade ember-cli to 3.4.4.

Anyway, I have it working at that and I have been able to get data into my Firebase database. This whole thing does seem to be a bit of mess of incompatible libraries and versions though - maybe it’s just me!

great to hear you are unblocked! Wading through dependency bugs can be incredibly frustrating; I’ve been bit by the problem more times than I care to count in ember applications that have a number dependencies. I commented on that issue as well because I think something still seems off.

@the_lar Sorry this has been your experience. These issue can definitely be frustrating, but I wouldn’t say this is the norm at all so hopefully that’s not your impression. EmberFire has been under pretty heavy development recently and there have been a couple issues in the newest Ember Dat release so I think it might just be a confluence of circumstances.

I could be wrong since they weren’t specific in the EmberFire issue thread but you may only need to downgrade Ember Data to <3.11 and leave ember-cli, etc at latest. Ember Data had one or more issues in the recent 3.11 release that broke some blueprint functionality. That may not fix everything for you and it sounds like you already found a way forward, but there’s a lot of cool features in Ember 3.10/3.11 so it would be nice to not have to go back that far (3.4.4) with everything.