The guides at Ember.js Guides - Guides and Tutorials - Ember Guides seem to mesh together the terms “content property”, and “model property”. I would have raised a bug - except I’m not so sure. Is this merely a typo? Or could we simply just standard on one term, and just call it that, instead of calling it by 2 different names?
You can see this in Specifying a Route's Model - Routing - Ember Guides, and http://emberjs.com/guides/routing/setting-up-a-controller/ (grep for ‘model property’)
Note: if it truly is a typo, I’d be glad to file it as a bug. But thought to check in here first.
I don’t think it’s really a bug, since in the controller they mean the same thing. But having two different words for the same thing makes it confusing, and doesn’t help with the docs.
There’s still no consensus on which property should prevail (or even if both). More info here: https://github.com/emberjs/ember.js/issues/2007
got it. Thanks! Glad to see that it’s not just me…
I saw @tom comment on an issue on GitHub and say, model == content and that model is the preferred property to use but for backwards compatibility content will be there for the time being.
thanks, guys! That clears it up for me very nicely. And i’m glad that we’re sticking with model!