Upgrade from Ember 1.9.1


#1

Hello,

I am new to this forum.

We have an Ember Application using version 1.9.1. We are thinking of upgrading it to at least 1.13 and then go on to Ember 2.0. What is the best of doing this? Please point any guides that will help in this transition.

Thanks.


#2

Just follow the deprecation guide:

Beware that depending on your app size, you may have a bunch of work to do in this upgrade… But there are some really good improvements in the 1.13+ version. =)


#3

Just wondering if it’s really necessary. I think start a new app and keep the another one unchanged is a good alternative. The drop of controllers, views and the rethink design approach can be very frustrante at first try.


#4

The controllers is not your biggest problem since it is still supported in the version 2.X, and it’s still required for some functionalities like queryParams… ArrayControllers might be a burden for you… Same for bind-attrs, and other deprecated helpers.

In my previous project we dropped the migration task from 1.11 to t.13 due to the amount of code refactoring we would have to do… So we kept it in the version 1.11, but in our new (current) project we started with the ember 2.1, keeping it always up to date (2.6 today).

Ember 1.13+ have a new rendering engine (glimmer) that improves the app’s performance, and it also have some better communication between components and the route/controller… I can’t list all the advantages of the newest versions compared to the 1.9, but these two are the most notable in the projects i’ve worked on.

It’s always good to have the earliest version running in your app, but just keep in mind the cost of this migration, and to set two different ember versions for a same project may become difficult to maintain :relaxed:


#5

Many thanks to all the responses. I started with Ember 1.11.1 mainly because we have another application in-house that is using 1.11.1. It was easy to reference it. Eventually I want to move to 1.13.

One question that I have, is there a blue print defined which tells us what version of other libraries (eg ember-data, jquery etc.) are compatible with a given Ember version. I want to make sure, I use the suggested versions of the libraries).

I had to make some changes in templates for #each and some issues with bind-attr. With these changes the application is running as before. But I see lot of warnings in the Chrome debug console.

The warnings seen in the Chrome console are for itemController and ObjectController. One of the controllers that is being used is ObjectController which seems to have been deprecated. Some of the templates use itemController. Any ideas how to go about fixing this will be useful.

Thanks.


#6

http://ember-cli.com/user-guide/#project-update

re run a ember init Then it’ll overwrite the packages and bower to a new one with correct deps.