Using ember-cli on a build server


#1

I am an extreme beginner with EmberJS and with the help of @eviltrout’s EmberJS without Data got myself going on building a new website. One of the things I am trying to do is to get the site to be automatically built using Shippable. I have been able to get the environment setup correctly to use install and run ember-cli however when running build I am presented with the following error (Some parts obfuscated or removed for privacy):

ember build --environment production
version: 0.0.44
BuildingBuild failed.
ENOENT, no such file or directory '/home/shippable/workspace/src/gtmp/tree_merger-tmp_dest_dir-AxzlVNdo.tmp/[modulePrefix]/models/store.js'
File: [modulePrefix]/models/store.js
Error: ENOENT, no such file or directory '/home/shippable/workspace/src/gtmp/tree_merger-tmp_dest_dir-AxzlVNdo.tmp/[modulePrefix]/models/store.js'
at Object.fs.statSync (fs.js:695:18)
at addModule (/home/shippable/workspace/src/gnode_modules/ember-cli/node_modules/broccoli-es6-concatenator/index.js:83:46)
at addModule (/home/shippable/workspace/src/gnode_modules/ember-cli/node_modules/broccoli-es6-concatenator/index.js:126:9)
at /home/shippable/workspace/src/gnode_modules/ember-cli/node_modules/broccoli-es6-concatenator/index.js:59:7
at $$$internal$$tryCatch (/home/shippable/workspace/src/gnode_modules/ember-cli/node_modules/rsvp/dist/rsvp.js:470:16)
at $$$internal$$invokeCallback (/home/shippable/workspace/src/gnode_modules/ember-cli/node_modules/rsvp/dist/rsvp.js:482:17)
at $$$internal$$publish (/home/shippable/workspace/src/gnode_modules/ember-cli/node_modules/rsvp/dist/rsvp.js:453:11)
at $$rsvp$asap$$flush (/home/shippable/workspace/src/gnode_modules/ember-cli/node_modules/rsvp/dist/rsvp.js:1531:9)
at process._tickCallback (node.js:419:13)
Build completed

It seems that the build process is trying to use the modulePrefix rather then app to find the models, and I would assume the same for anything else afterwards. How can I set up the build environment to use the app folder to find the relevant source code.

When building the site on my local machine it does work perfectly.


#2

I had something like this after upgrading to a new ember-cli version. I created a new project to check if the new bower.json and the package.json contained the same modules and versions in my project. This was not the case and changing these files in my project to the same modules and versions as the new project solved this kind of errors for me. I had to run npm install en bower install after the change. I hope it is as simple as this for you too.


#3

Thank you. I tried your suggestions and all the versions on the build server is correct. I am still trying to troubleshoot but also trying using a Yeoman generated ember site and seeing if that will work.


#4

I am also learning and I will stick with ember-cli What happens when you ember generate model testing is testing.js the same as your store.js?

My working ember-cli 0.0.44 example https://github.com/broerse/ember-cli-blog