Webpack Returned Errors to ember-auto-import

I have a problem build error like title of my topic, anyone can help me?

here’s my package.json

devDependencies: {
    "@ember/jquery": "^0.5.2",
    "@ember/optional-features": "^0.6.3",
    "broccoli-asset-rev": "^2.7.0",
    "ember-ajax": "^3.1.0",
    "ember-cached-shoe": "^0.2.0",
    "ember-cli": "^3.8.1",
    "ember-cli-app-version": "^3.2.0",
    "ember-cli-babel": "^6.16.0",
    "ember-cli-bundle-analyzer": "0.0.3",
    "ember-cli-concat": "^1.3.0",
    "ember-cli-dependency-checker": "^3.0.0",
    "ember-cli-eslint": "^4.2.3",
    "ember-cli-fastboot": "^2.0.0",
    "ember-cli-head": "^0.4.1",
    "ember-cli-htmlbars": "^3.0.0",
    "ember-cli-htmlbars-inline-precompile": "^1.0.3",
    "ember-cli-inject-live-reload": "^1.8.2",
    "ember-cli-less": "^1.5.5",
    "ember-cli-moment-shim": "^3.7.1",
    "ember-cli-qunit": "^4.3.2",
    "ember-cli-shims": "^1.2.0",
    "ember-cli-sri": "^2.1.1",
    "ember-cli-string-helpers": "^1.9.0",
    "ember-cli-template-lint": "^1.0.0-beta.1",
    "ember-cli-uglify": "^2.1.0",
    "ember-concurrency": "^0.8.19",
    "ember-data": "~3.4.0",
    "ember-export-application-global": "^2.0.0",
    "ember-font-awesome": "^4.0.0-rc.4",
    "ember-in-viewport": "^3.1.5",
    "ember-link-action": "^0.1.3",
    "ember-load-initializers": "^1.1.0",
    "ember-maybe-import-regenerator": "^0.1.6",
    "ember-moment": "^7.7.0",
    "ember-resolver": "^5.0.1",
    "ember-screen": "^1.0.0",
    "ember-service-worker": "^0.7.0",
    "ember-source": "~3.4.0",
    "ember-web-app": "^2.3.0",
    "eslint-plugin-ember": "^5.2.0",
    "loader.js": "^4.7.0",
    "qunit-dom": "^0.7.1"
  },

I’am using ember-cli: 3.10.1, node: 10.16.0, os: win32 x64.

Please someone help me, thanks.

Please share the contents of the error.dump.*.log file.

What library are you trying to import using ember-auto-import?

Thanks for your reply @ef4,

First thing is I’m not sure where I use the ember-auto-import and what for, cause I just clone my client’s repo, and where I try to find ‘ember-auto-import’ in the app, I found nothing. But here’s the log, I share the link where I post the log cause the automated spam filter, Akismet, always temporarily hidden my post when I post the log in reply.

It looks like probably ember-cached-shoe uses ember-auto-import to load b2a.

I’m not seeing the original webpack error for some reason, I wonder if we have a windows bug that causes it not to be printed. Hmm.

Do you get any additional output if you set the environment variable AUTO_IMPORT_VERBOSE=true?

Yes, I see in the log that’s all caused by ember-cached-shoe.

How to set the environment variable AUTO_IMPORT_VERBOSE btw?

The log change to be like this if I remove ember-cached-shoe package

How to set the environment variable AUTO_IMPORT_VERBOSE btw?

You can run AUTO_IMPORT_VERSION=true ember b, another fun one is DEBUG=* ember b but beware you get a LOT of output.

In Powershell, you can run

Set-Item Env:AUTO_IMPORT_VERBOSE "true"

before you run ember s

And FWIW, I confirmed that ember-auto-import does print webpack errors when used on windows, so I still don’t know why you aren’t seeing more useful feedback.

Ya, the problem is the webpack errors when I using ember-cached-shoe, and I need ember-cached-shoe for the router, I’am asking because all of my friends on the same project and using windows can work properly using ember-auto-import.

Is this is only breaking on your machine, have you tried removing all node_modules and reinstalling them? It could be that simple.

I just checked and I can build an app with ember-cached-shoe on windows.

Yes, but I’ve tested it on two devices of mine. I already tried removing all node_modules and reinstalling all of it, I also already tried to downgrade my ember-cli version, node and npm version but still have same result of error.

Did you get any additional console output using AUTO_IMPORT_VERBOSE? That should really cause some additional detail to print.

If anyone’s issue has not been resolved yet…I have a suggestion. I realized that when my auto import threw errors, I moved my ember project outside of my main directory (typically your C:// drive). This actually caused the issue, because it can not find this particular plugin (broccoli-builder I believe). I put my project BACK INTO THE C:// DRIVE (it worked). Once I finally remembered how I resolved this (30 mins to an hour later), I decided to put this in here to help anyone out and for me to have a friendly reminder placed somewhere.

This is how my package json file look (so you will know the current versions of everything I running): {

“name”: “emb-app”,

“version”: “0.0.0”,

“private”: true,

“description”: “Small description for emb-app goes here”,

“repository”: “”,

“license”: “MIT”,

“author”: “”,

“directories”: {

"doc": "doc",

"test": "tests"

},

“scripts”: {

"build": "ember build --environment=production",

"lint": "npm-run-all --aggregate-output --continue-on-error --parallel lint:*",

"lint:hbs": "ember-template-lint .",

"lint:js": "eslint .",

"start": "ember serve",

"test": "npm-run-all lint:* test:*",

"test:ember": "ember test"

},

“devDependencies”: {

"@ember/optional-features": "^1.3.0",

"@glimmer/component": "^1.0.0",

"@glimmer/tracking": "^1.0.0",

"babel-eslint": "^10.1.0",

"broccoli-asset-rev": "^3.0.0",

"ember-animated": "^0.10.0",

"ember-auto-import": "^1.5.3",

"ember-cli": "^3.17.0",

"ember-cli-app-version": "^3.2.0",

"ember-cli-babel": "^7.18.0",

"ember-cli-dependency-checker": "^3.2.0",

"ember-cli-htmlbars": "^4.2.3",

"ember-cli-inject-live-reload": "^2.0.2",

"ember-cli-sass": "^10.0.1",

"ember-cli-sri": "^2.1.1",

"ember-cli-uglify": "^3.0.0",

"ember-data": "~3.17.0",

"ember-export-application-global": "^2.0.1",

"ember-fetch": "^7.0.1",

"ember-load-initializers": "^2.1.1",

"ember-maybe-import-regenerator": "^0.1.6",

"ember-prism": "^0.6.1",

"ember-qunit": "^4.6.0",

"ember-resolver": "^7.0.0",

"ember-source": "~3.17.0",

"ember-template-lint": "^2.4.0",

"ember-welcome-page": "^4.0.0",

"eslint": "^6.8.0",

"eslint-plugin-ember": "^7.10.1",

"eslint-plugin-node": "^11.0.0",

"loader.js": "^4.7.0",

"npm-run-all": "^4.1.5",

"qunit-dom": "^1.1.0",

"sass": "^1.26.3"

},

“engines”: {

"node": "10.* || >= 12"

},

“ember”: {

"edition": "octane"

}

}

I’ve just received this error, console logging was helpful. I was importing css as advised which breaks the import.

import ‘suneditor/dist/css/suneditor.min.css’

I’ll move it to styles where it belongs.