Weird QueryParams Problem after upgrading from 1.6 Canary to 1.7


#1

Hello,

I have a strange Problem, with the queryParams binding between Router and Controller. I was using an older canary build: version as: “1.6.0-beta.1+canary.310dc702”

With this i had a working application similair to http://emberjs.jsbin.com/ucanam/6056/edit

No Problems so far. After Upgrading to the latest official 1.7 Release the Binding stopped working controller side. Changing an attribute defined in “queryParams” did not update the route anymore, although the attribute was set (checked with ember debugger). The other way arround (changing URL->Updating attribute in Controller) worked perfectly.

I tried different older Betas, an newer Canaries. The only Version which seem to work with my App is the on stated above.

I would like to dig deeper to investigate, but i don’t know how to debug the hooks and bindings in Ember.

Any Ideas? Suggestions? Any help is arppicatiated.


#2

The implementation of query params went through a few iterations, and it is possible that the internals changed between your prior version and the final stable one.

If you can reproduce the problem in a JSBin, please open an issue in the main repo so we can track it down.