Where is Ember?


#1

Finally after having installed ember thru Choco I type what the guide says to do in the command line. CLI repons No such internal or external command. I would have thought, since I was told to type it that Ember was added to my path statement. To make matters worse, I can’t find Ember myself. It is not in either Program Files folder. I am running Win 8.1 64bit. And have sucessfully downloaded Ember.


#2

I am on Windows so perhaps I can help you. I don’t know what Choco is but if you have installed node from www.nodejs.org and run:

  • npm install -g ember-cli
  • npm install -g bower
  • ember new my-new-app
  • cd my-new-app
  • ember s

All should work.


#3

Thanks broerse. I guess I didn’t make myself clear. I was able to install Ember, but it’s not in my Path statement and I need to know what folder that it is in so I can add it to the PATH Thanks, Paul


#4

It is in: C:\Users\paul\AppData\Roaming\npm


#5

C:>ember new my-app ’ember’ is not recognized as an internal or external command, operable program or batch file.

Tried to add it to my PATH using your pat to ember but this is what I got:(

There are two files named Ember at that location. Since double-clicking ember.cmd got me a CLI with a blinking white bar, I added this one to the pateh. Will try the other next


#6

node should set the path for you on installation. Perhaps reinstall node and than run this?

  1. npm uninstall -g ember-cli – Remove old global ember-cli
  2. npm cache clean – Clear NPM cache
  3. bower cache clean – Clear Bower cache
  4. npm install -g ember-cli@0.2.3 – Install new global ember-cli

#7

All I’m getting is just page after page of errors :frowning:


#8

Ok, forget all the other garbage, using npm alone I was able to install ember. Unfortunately, I have errors. When I tried to create my-app this is what I got:

 **c:\>ember new my-app**
**version: 0.2.3**
**0.2.3**

**installing**
  **create .bowerrc**
  **create .editorconfig**
  **create .ember-cli**
  **create .jshintrc**
  **create .travis.yml**
  **create Brocfile.js**
  **create README.md**
  **create app\app.js**
  **create app\components\.gitkeep**
  **create app\controllers\.gitkeep**
  **create app\helpers\.gitkeep**
  **create app\index.html**
  **create app\models\.gitkeep**
  **create app\router.js**
  **create app\routes\.gitkeep**
  **create app\styles\app.css**
  **create app\templates\application.hbs**
  **create app\templates\components\.gitkeep**
  **create app\views\.gitkeep**
  **create bower.json**
  **create config\environment.js**
  **create .gitignore**
  **create package.json**
  **create public\crossdomain.xml**
  **create public\robots.txt**
  **create testem.json**
  **create tests\.jshintrc**
  **create tests\helpers\resolver.js**
  **create tests\helpers\start-app.js**
  **create tests\index.html**
  **create tests\test-helper.js**
  **create tests\unit\.gitkeep**
  **create vendor\.gitkeep**
**ENOENT, open 'c:\package.json'**
**Error: ENOENT, open 'c:\package.json'**
    **at Error (native)**

How ever it did create a folder/subfolders my-app.

From there I tried run the server. This what I got:

c:\my-app>ember server version: 0.2.3 Cannot find module 'ember-cli/lib/broccoli/ember-app’ Error: Cannot find module 'ember-cli/lib/broccoli/ember-app’ at Function.Module._resolveFilename (module.js:336:15) at Function.Module._load (module.js:278:25) at Module.require (module.js:365:17) at require (module.js:384:17) at Object. (c:\my-app\Brocfile.js:3:16) at Module._compile (module.js:460:26) at Object.Module._extensions…js (module.js:478:10) at Module.load (module.js:355:32) at Function.Module._load (module.js:310:12) at Module.require (module.js:365:17)

Apparently the server is not running because when I try localhost:I get:a Page Not Found error. Any solutions? Thanks, Paul


#9

I have seen this too but was thinking it was a npm glitch. If you just for testing run ember new tttttt it will probably work. Perhaps we need to report this as a bug.


#10

I don’t understand you? ember new tttttt is exactly the same as ember new my-app why should emb er new tttttt work when ember new my-app doesn’t?


#11
**ENOENT, open 'c:\package.json'**
**Error: ENOENT, open 'c:\package.json'**
    **at Error (native)**

looks like C:\package.json doesn’t exist.

I think the problem is that you ran ember new in C:\ as your pwd. Maybe windows doesn’t allow writing there. Try somewhere else, i.e. your user directory.

(something like (I don’t know windows): cd %userprofile% then ember new my-app, cd my-app and there run your ember commands`)


#12

Did you try it? It solves the problem for me.


#13

No, I just tried the same thing as before. ember new name. I put the folder in c:\ as before but with no error. even ember server worked also so now I have a page that says “It Works!”. What now? Is there a tutorial for creating a blog or something? Thanks, Paul


#14

I think if you are on windows put all you projects in a folder like c:\dev and disable the virus scanner and search index for that folder. This will speedup ember rebuilds.

My blog example: