Cannot execute `ember new` due to `git://` issue


#1

I’ve asked this question on StackOverflow, but thought maybe this would be a better place for this issue. http://stackoverflow.com/questions/26606367/unable-to-start-ember-cli-project-because-of-git-error

When I try to execute ember new myproject I get the following:

[ ... snip ...]
  create vendor/.gitkeep
Installed packages for tooling via npm.
Failed to execute "git ls-remote --tags --heads git://github.com/stefanpenner/ember-load-initializers.git", exit code of #128
Error: Failed to execute "git ls-remote --tags --heads git://github.com/stefanpenner/ember-load-initializers.git"
 exit code of #128
    at createError (/usr/local/lib/node_modules/ember-cli/node_modules/bower/lib/util/createError.js:4:15)
    [ ... snip ...]

So I tried to execute the failing command:

$ git ls-remote --tags --heads git://github.com/stefanpenner/ember-load-initializers.git
fatal: unable to connect to github.com:
github.com[0: 192.30.252.131]: errno=Operation timed out

The git://github.com syntax was new to me, so I tried a version with the more familiar git@github.com::

$ git ls-remote --tags --heads git@github.com:stefanpenner/ember-load-initializers.git                                                                                        
3a6dc87e29efc9de4bc42b6f9afedabb000bcc89        refs/heads/master
be13fa4a45abff2c9fcfc82497668ed2a925a856        refs/tags/0.0.1
3a6dc87e29efc9de4bc42b6f9afedabb000bcc89        refs/tags/v0.0.2
$

Can anyone help me diagnose this issue? I’d be happy with a git solutionor anember` workaround.

I have also tried:

$ ember new myproject --skip-git

with the same result. I’ve also tried

$ ember new myproject --skip-bower

which seems to compete successfully, but then give an error on $ ember serve, complaining about the lack of bower components.

If I then try:

$ bower install

Then I get the same git:// problem. So I guess this is really a bower/git problem. Much appreciate suggestions.