Check if Windows Symlink is enabled or not

#1

Is there any way to check whether Symlink is enabled or not on a Windows machine without admin access i.e. if I do not have access to go to the Local Security Policy ?

So may be via some sort of command or any workaround ?

0 Likes

#2

I don’t have an answer for your specific question, but I do offer my sympathies trying to do Ember development on Windows. I tried to get my Windows machine set up for a couple months last year with a lot of frustration. I then tried Windows Subsystem for Linux with some success, but eventually I just went back to Linux proper.

0 Likes

#3

Ember CLI uses https://www.npmjs.com/package/can-symlink, at least it used to. :slight_smile:

0 Likes

#4

See the original post on Symlinks in Windows 10! that includes the following example:

Developing on Windows isn’t that bad once you disable Search Indexing and Windows Defender Real-Time Scanning. Build times are roughly 3x compared to macOS running on the same machine, but not the 30x that they used to be. See also ember-cli-windows for further improvements.

0 Likes