Ember Tests Page Returns 404 Error


#1

Hi,

I already posted this to Stack Overflow, but received no response there. An ember developer told me that I have a better chance of getting a response here, so maybe somebody here can help me?

I’m trying to add unit tests to an existing project that was developed over the last two years and updated regularly to newest ember version.

To do that, I started by running

$ ember test -s
version: 1.13.13
Building...

Build successful - 11946ms.

The process is started, but then the web browser opens and I get the following error message in the browser window:

Not found: /7596/tests/index.html?hidepassed

The number changes, but I can remove it to get the same result. Accessing / just redirects to /tests/index.html?hidepassed, with the same result.

Here’s the output of curl:

$ curl -i http://localhost:7357/tests/index.html?hidepassed
HTTP/1.1 404 Not Found
X-Powered-By: Express
Cache-Control: No-cache
Pragma: No-cache
Content-Type: text/html; charset=utf-8
Content-Length: 39
ETag: W/"27-KHWxXB+A/SkhyzCtPXoJ4Q"
Date: Wed, 02 Dec 2015 16:41:22 GMT
Connection: keep-alive

Not found: /tests/index.html?hidepassed

When the unit test server is not running, the port is closed, so it appears to be the right web server and not something else on my system.

When I create a new project with ember-cli the test page works fine. I have compared all files in the tests directory, testem.json, ember-cli-build.js, bower.json and package.json, but I’m unable to locate any difference that could cause this issue.

Does anybody have an idea what I could look for to get this working with my existing project?

I’m running ember 2.2.0 and ember-cli 1.13.13. If it makes any difference, the ember project usually is run through ember-cli-rails-addon.


#2

What do you have in your ember-cli-build.js file? Any possibility you disabled the tests building there?

When you build your app with ember build do you have a dist/tests folder and an index.html there?