Files in tmp added to watch list


#1

I’ve started encountering some problems running ember serve today. I see a number of lines like this:

file added tmp\babel-output_path-3AvwS5YU.tmp\project-name\tests\helpers

This looks to me as if files under tmp are getting added to the watched files list. After these appear, I get a large number of EPERM and ENOENT errors, then the process exits, e.g.

EPERM, operation not permitted 'C:\Projects\project-name\tmp\funnel-output_path-nLpHnwxn.tmp'

I’ve installed up-to-date versions of ember and node, and been through several iterations of removing tmp, node_modules and bower_components, followed by npm cache clean and bower cache clean, reinstalling ember etc. but the problem still persists. It has to be something in my setup/configuration, since a colleague can serve the same code successfully. Maybe something to do with the watcher configuration? I’m on Windows, if that makes any difference.

Thanks!


#2

Did you try ember new dummy to see if it is in your project or your setup?


#3

Thanks for the suggestion! I did actually create another new app yesterday and it worked fine.

I’ve been doing some tests this morning and have found that the build errors go away when I remove this line from my package.json:

"ember-browserify": "^1.0.1"

We are using this to bring in the humanize-plus package. Interestingly this works on another developer’s machine, which leads me to believe it must be a configuration issue.

EDIT: To clarify, the process I followed to find this out was to create a new app via ember new, copy the package.json and bower.json files from the failing app, then npm install and bower install. At that point, the build of the new (empty) app failed in the same way as the original app. I then removed items from package.json until the build worked, and found that the only one I needed to remove to get rid of the errors was ember-browserify.


#4

Strange. There is a ember-browserify 1.0.5 but the changes don’t fix issues like yours. Perhaps install 1.0.5 anyway to see what happens?