Getting Started, dist, 404


#1

I’m new to Ember so I started with the tutorial on the emberjs website. Everything went perfectly in development. I added two routes, per the getting started tutorial. I did ’ ember build --env production’ and then copied the ‘/dist’ folder to my webserver root folder (I’m using an asmallorange.com apache hosting environment). When I go to the root url, there are no errors, console or otherwise but when I go to one of the routes I just get ‘404’.

So, what else is there to deployment? Either I’m missing something or the guide isn’t complete. Do I need to add an argument or parameter to the build command? What needs to be on my hosting environment that I might be missing? Is all that is necessary is to upload the contents of the /dist folder to the webserver? Help!

TIA


#2

Solved it by spending some more time browsing the forum. This is a tricky topic to search. It should really be in the getting started ‘deployment’ section; at least a link for Apache users? Anyway, I added the standard framework .htaccess file. Not my first framework. I should have realized :smiley:

RewriteEngine On RewriteRule ^index\.html$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule (.*) index.html [L]

#3

Hi @Sinrise! Do you mean this part of the tutorial: https://guides.emberjs.com/v2.9.0/tutorial/deploying/ ?

Can you make a Pull Request to the guides adding this bit of information? You can find a pencil icon on the top-right that will take you straight to the file in the GitHub interface.


#4

I would be happy to! Thanks.


#5

Hi all, I have the same problem as @Sinrise. I try to run turorial example https://guides.emberjs.com/v2.12.0/tutorial/deploying/ on Apache on Windows 7. Root url ‘http://localhost’ works fine , but when I have something more like ‘http://localhost/about’ and then refresh url I receive 404 error.

I enable rewrite mod on httpd.conf (LoadModule rewrite_module modules/mod_rewrite.so) and added .htaccess file to root folder on apache ‘c:\Apache24\htdocs’ but it doesn’t work.

What should I do more?