Quick Ember tutorial


#1

I am just starting with Ember and tried the quickstart tutorial. I just can’t get it to work when I deploy the dist folder to my website. I have tried it twice now and it just won’t work. As far as I can tell, the Application.hbs file never has anything in it but

People Tracker

. and {{outlet}} below that.

If I use the builtin webserver and view the scientist page I see what I should. If I upload the dist folder to my website and try to view index.html I see a blank page.

I don’t mean to be rude but I have had no luck with stackoverflow. The administrators there are arrogant and rude. If no results here I will just have to try another framework. Thanks, Paul


#2

There are multiple things that could go wrong. If you upload your dist folder after running ember build production to a subfolder you should specify it here.

If you upload to an Apache server add this .htaccess file. https://github.com/broerse/ember-cli-blog/blob/6c22ff21e69c383ec3b5f55300e2cfa58d6d8de3/public/.htaccess

If this does not work you can go to you dist folder and see if it works by running http-server (after `npm install -g http-server)


#3

This may happen if there are errors as Ember is loading up, is there anything in your browser’s console about errors?


#4

Thanks, broerse, I will try to find and modify the environment.js file Acorncom, There were no errors in the broswer, just a blank page. I did notice when trying to use Ember Developer on the page I got That it was not a Ember page. I think the next thing I will try is just to deploy the default app that you get with a default app you know, before you modify anything. Paul


#5

Another thing worth trying would be to ask on the Ember Slack help channel. This is the type of thing it’s easier to debug in realtime …


#6

If you can provide any details, we may be able to suggest something. Are you actually putting the /dist folder on a server or just the contents - and is it in a subfolder? What hosting are you using? Depending on the host you could be experiencing one or many things because of .htaccess or something that is not Ember specific.