Heroku Deploy - "sh: bower: not found"


#1

I am using the heorku-buildpack-ember-cli, but when I push to heroku and my dependencies begin to install, I immediately get the following error from my ember-cli-bootstrap addon’s post install:

> ember-cli-bootstrap@0.0.12 postinstall /tmp/build_8997e52c-3cf3-4a16-ab57-bb9e124b8bd8/node_modules/ember-cli-bootstrap
   > bower install
   
   sh: bower: not found
   npm ERR! ember-cli-bootstrap@0.0.12 postinstall: `bower install`
   npm ERR! Exit status 127
   npm ERR! 
   npm ERR! Failed at the ember-cli-bootstrap@0.0.12 postinstall script.
   npm ERR! This is most likely a problem with the ember-cli-bootstrap package,
   npm ERR! not with npm itself.
   npm ERR! Tell the author that this fails on your system:
   npm ERR!     bower install
   npm ERR! You can get their info via:
   npm ERR!     npm owner ls ember-cli-bootstrap
   npm ERR! There is likely additional logging output above.
   
   npm ERR! System Linux 3.8.11-ec2
   npm ERR! command "/tmp/build_8997e52c-3cf3-4a16-ab57-bb9e124b8bd8/vendor/node/bin/node" "/tmp/build_8997e52c-3cf3-4a16-ab57-bb9e124b8bd8/vendor/node/bin/npm" "install" "--quiet" "--userconfig" "/tmp/build_8997e52c-3cf3-4a16-ab57-bb9e124b8bd8/.npmrc"
   npm ERR! cwd /tmp/build_8997e52c-3cf3-4a16-ab57-bb9e124b8bd8
   npm ERR! node -v v0.10.32
   npm ERR! npm -v 1.4.28
   npm ERR! code ELIFECYCLE
   npm ERR! not ok code 0

I have tried quite a few solutions from similar problems, like adding a postinstall script and adding bower to the dependencies in package.json, but nothing has worked thus far.

Any suggestions would be much appreciated.

Thanks, Ben H


#2

Most likely cause:

You have "postinstall": "bower install" in your package.json but you do not have bower listed in your applications dependencies.


#3

@rwjblue My package.json:

 {
  "name": "frontend",
  "version": "0.0.0",
  "private": true,
  "directories": {
    "doc": "doc",
    "test": "tests"
  },
  "scripts": {
    "start": "ember server",
    "build": "ember build",
    "test": "ember test",
    "postinstall": "bower install"
  },
  "repository": "https://github.com/stefanpenner/ember-cli",
  "engines": {
    "node": ">= 0.10.0"
  },
  "author": "",
  "license": "MIT",
  "devDependencies": {
    "body-parser": "^1.2.0",
    "broccoli-asset-rev": "^0.3.1",
    "broccoli-ember-hbs-template-compiler": "^1.6.1",
    "ember-cli": "0.1.1",
    "ember-cli-bootstrap": "0.0.12",
    "ember-cli-content-security-policy": "^0.2.1",
    "ember-cli-datepicker": "^1.2.2",
    "ember-cli-dates": "0.0.8",
    "ember-cli-ic-ajax": "0.1.1",
    "ember-cli-inject-live-reload": "^1.2.2",
    "ember-cli-qunit": "^0.1.0",
    "ember-cli-simple-auth-devise": "^0.6.7",
    "ember-data": "^1.0.0-beta.10",
    "express": "^4.8.5",
    "glob": "^4.0.5",
    "bower": "^1.3.12"
  },
  "dependencies": {
    "bower": "^1.3.12",
    "ember-cli-dates": "0.0.8"
  }
}

#4

Issue is with ember-cli-bootstrap: https://github.com/dockyard/ember-cli-bootstrap/issues/23


#5

I’m having this problem even without ember-cli-bootstrap.

i’m using ember-cli 2.2.0, and bower 1.4.1