Octane :: Creating a new application

#1

Hi, I try to create new app in Octane by typing

ember new my-app -b @ember/octane-app-blueprint

but I get following error:

Error creating new application. Removing generated directory ./my-app connect ECONNREFUSED 0.0.0.0:443

Content with error report:

=================================================================================

ENV Summary:

TIME: Mon Mar 25 2019 19:09:26 GMT+0100 (Central European Standard Time) TITLE: ember ARGV:

  • /usr/bin/node
  • /usr/bin/ember
  • new
  • my-app
  • -b
  • @ember/octane-app-blueprint EXEC_PATH: /usr/bin/node TMPDIR: /tmp SHELL: /bin/bash PATH:
  • /usr/local/bin
  • /usr/bin
  • /bin
  • /usr/local/games
  • /usr/games PLATFORM: linux x64 FREEMEM: 147275776 TOTALMEM: 1040089088 UPTIME: 646507 LOADAVG: 0.2646484375,0.17529296875,0.15234375 CPUS:
  • Intel® Xeon® CPU E5-2650L v4 @ 1.70GHz - 1699 ENDIANNESS: LE VERSIONS:
  • ares: 1.15.0
  • cldr: 33.1
  • http_parser: 2.8.0
  • icu: 62.1
  • modules: 64
  • napi: 3
  • nghttp2: 1.34.0
  • node: 10.15.3
  • openssl: 1.1.0j
  • tz: 2018e
  • unicode: 11.0
  • uv: 1.23.2
  • v8: 6.8.275.32-node.51
  • zlib: 1.2.11

ERROR Summary:

  • broccoliBuilderErrorStack: [undefined]
  • code: ECONNREFUSED
  • codeFrame: [undefined]
  • errorMessage: connect ECONNREFUSED 0.0.0.0:443
  • errorType: [undefined]
  • location:
    • column: [undefined]
    • file: [undefined]
    • line: [undefined]
  • message: connect ECONNREFUSED 0.0.0.0:443
  • name: RequestError
  • nodeAnnotation: [undefined]
  • nodeName: [undefined]
  • originalErrorMessage: [undefined]
  • stack: RequestError: connect ECONNREFUSED 0.0.0.0:443 at ClientRequest.req.once.err (/tmp/ember-cli2019225-6340-107pjnu.87jx/node_modules/got/index.js:182:22) at Object.onceWrapper (events.js:277:13) at ClientRequest.emit (events.js:189:13) at TLSSocket.socketErrorListener (_http_client.js:392:9) at TLSSocket.emit (events.js:189:13) at emitErrorNT (internal/streams/destroy.js:82:8) at emitErrorAndCloseNT (internal/streams/destroy.js:50:3) at process._tickCallback (internal/process/next_tick.js:63:19)

=================================================================================

Can someone help me and write what I do wrong?

Thanks for help :slight_smile:

0 Likes

#2

Do you have a proxy set up or maybe some local DNS overrides? It seems like something is interfering with your localhost’s https port.

2 Likes

#3

You are right :slight_smile:

My PiHole blocked communication…

1 Like