Problem with Internet Explorer not showing changes to model unless page is refreshed


#1

I have a problem with Internet Explorer not showing changes unless I hit F5 (refresh).

Scenario:

I have a page with a link that opens a modal window (where I do my editing). This works fine. I can make my changes and click my ‘OK’ button, which closes my modal window. The calling page does not show the changes unless I hit F5. It works perfectly in Chrome and Firefox.

Using Chrome and Fiddler, I can see that a GET is called right after my PUT (clicking the ‘OK’ button). In Internet Explorer, I don’t see the GET after the PUT.


#2

What version of Internet explorer?


#3

I am using Version 11.


#4

I just notice that IE will perform the GET after the PUT but only if I have the developer tools open.


#5

Well…my app appears to work fine once it has been built and deployed. If I run ‘ember server’ on my local box, Internet Explorer still doesn’t show the update until the page refreshes.


#6

Have you figured out a solution to this problem? Running into the same issue with the Ember application I’m working on, and am completely stuck.


#7

I believe it was a ‘console.log’ I had in my code. Once I removed it, it worked fine.

http://kevinquillen.com/ie/2014/06/11/ie-console-woes/