Ember Data - PATCH operation with Internet Explorer 10 & 11


#1

I apologize if this question has been asked and answered before. Unfortunately, the search terms are such that it brings back a lot of conversations that are unrelated.

We have made very good progress with our Ember -> Ember Data -> JSON API -> Java server implementation and were really happy with the way it is behaving. I still need to resolve “included” resources (per another topic I posted), but we felt we were OK for the moment to go live… until we tested on IE 10 an 11 and found that it was not working.

Our first issue was the need to send P3P headers along with the server cookies in order for IE to accept the cookies and use them for our authentication system. After resolving that, we are able to talk to our secure API, however attempts to update objects using HTTP PATCH method are failing in IE 10 and 11. In IE 11, it fails mostly silently, while in IE 10 it logs a “Permission Denied” error. In both cases, it does not attempt to make any network call and instead blocks the request.

Has anyone else seen this? Any suggestions of what might be going on and how we can get PATCH operations to work with Internet Explorer? I should add that this does work correctly in MSFT Edge browser.

Thanks in advance, Craig


#2

After more digging, I believe the issue I’m seeing is due to a jQuery bug (see https://github.com/jquery/jquery/pull/2183). This bug is fixed in jQuery 1.12, however my current ember dependencies have 1.11.3. In updating the Ember dependencies, I changed to 1.12, but then I’m encountering the following error:

Error: Assertion Failed: Ember Views require jQuery between 1.7 and 2.1

I then attempted to change my Ember dependencies to the latest 1.13 version, however I’m then getting a dependency version resolution issue:

Unable to find a suitable version for ember, please choose one: 1) ember#>= 1.8.1 < 2.0.0 which resolved to 1.13.11 and is required by ember-data#1.13.15 2) ember#1.13.12 which resolved to 1.13.12 and is required by bv-ember-application 3) ember#>=1.4 <2 which resolved to 1.13.13 and is required by ember-cli-shims#0.0.3 4) ember#> 1.5.0-beta.3 which resolved to 2.3.0 and is required by ember-resolver#0.1.21 5) ember#^2.3.0 which resolved to 2.3.0

Can anyone steer me in the right direction to get my dependencies corrected such that I can use jQuery 1.12 with my application?

Thanks again, Craig


#3

@Craig_Setera, add/update the following in bower.json:

   "dependencies": {
 ......
  },
  "resolutions": {
    "ember": "1.13.13"
  }
```

Hope this helps

#4

That worked! And the newer versions of the dependencies resolved the issue with IE 11, Ember Data and PATCH.

Thanks for the help! Craig