Ember build failed with deprection message

Hi my ember project buld fails with the following error message and I have no idea in how to solve this issue:

  • ember-cli: 3.25.2

  • node: 14.9.0

  • os: linux x64

    Environment: development building… [Babel: ember-models-table > applyPatches]DEPRECATION: The use of the private {{-in-element}} is deprecated, please refactor to the public {{in-element}}. (‘ember-basic-dropdown/templates/components/basic-dropdown/content.hbs’ @ L1:C0) [deprecation id: glimmer.private-in-element] at logDeprecationStackTrace (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:1968:21) at HANDLERS. (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:2101:9) at raiseOnDeprecation (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:1995:9) at HANDLERS. (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:2101:9) at invoke (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:2113:9) at deprecate (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:2069:28) at BlockStatement (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:19832:55) at visitNode (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:11762:16) at visitArray (/mnt/c/git/tisweb/tiswebclient/node_modules/ember-source/dist/ember-template-compiler.js:11854:20) cleaning up… Template Compiler Error (broccoli-persistent-filter:TemplateCompiler) in ember-basic-dropdown/templates/components/basic-dropdown/content.hbs

    Cannot read property ‘type’ of undefined

Have you tried to clean everything and build the project again? Usually I do this:

rm -rf node_modules tmp && yarn && yarn start --port 4200

yes tried it a couple of times but still not working. its weird cause at home on my mac everything works fine (except the deprecation warning appears) but in the office on windows it fails :frowning:

@Marco_Musolf - Could you please share the solution if this is resolved ? I am getting same error upgrading ember application from 3.14 to 3.16. My development environment is Linux

I solved above issue. reason was an outdated dependency. by upgrading this dependency there is still a deprecated warning in the log but the build was successfull :slight_smile: old version “ember-power-select”: “^2.3.5” new version: “ember-power-select”: “^4.1.3”