Ember-CLI doesn't create any directories/files


#1

Hey guys,

I came across an odd problem with ember-cli.

Running the usual ember new <project-name> or ember addon <addon-name> runs successfully with no error messages however no directories or files get created in the file system.

Looking through Finder or doing ls doesn’t show the new project, I cannot cd into the supposedly created directory and mkdir <project-name> works fine (there’s no naming clash).

Additionally, when I try to re-run either commands using the same project name I get a message Directory <project-name> already exists even though it doesn’t.

Configurations:

ember-cli: 2.4.2
node: 0.12.7

npm: 3.7.3

OSX El Capitan 10.11.5

Here’s a graphical example of what is happening:

I created an empty directory and did ls and du on it:

16:44:36 › du -sh .
  0B	.
16:44:45 › ls -a
.  ..

Then I created a new ember project:

16:44:56 › ember new test-project 
installing app
  create .bowerrc
  create .editorconfig
  create .ember-cli
  create .jshintrc
  create .travis.yml
  create .watchmanconfig
  create README.md
  create app/app.js
  create app/components/.gitkeep
  create app/controllers/.gitkeep
  create app/helpers/.gitkeep
  create app/index.html
  create app/models/.gitkeep
  create app/resolver.js
  create app/router.js
  create app/routes/.gitkeep
  create app/styles/app.css
  create app/templates/application.hbs
  create app/templates/components/.gitkeep
  create bower.json
  create config/environment.js
  create ember-cli-build.js
  create .gitignore
  create package.json
  create public/crossdomain.xml
  create public/robots.txt
  create testem.js
  create tests/.jshintrc
  create tests/helpers/destroy-app.js
  create tests/helpers/module-for-acceptance.js
  create tests/helpers/resolver.js
  create tests/helpers/start-app.js
  create tests/index.html
  create tests/integration/.gitkeep
  create tests/test-helper.js
  create tests/unit/.gitkeep
  create vendor/.gitkeep
Successfully initialized git.
Installed packages for tooling via npm.
Installed browser packages via Bower.

And re-did the two commands from above:

16:46:39 › du -sh .
  0B	.
16:47:52 › ls -a
.  ..

Try it again:

16:50:42 › ember new test-project
Directory 'test-project' already exists.

Does anybody have an idea what’s going on?


UPDATE

I tried updating to the latest safe node/ember-cli and no changes:

ember-cli: 2.5.1
node: 5.11.1

npm: 3.9.2

I even checked if somehow I ran out of storage but I have around 30 GB free so that’s not it either.