New ember-cli project not working


#1

I have a very strange issue where I’m not able to serve/build new ember-cli projects.

My setup is: Windows 8.1, ember-cli 0.1.5, node 0.10.30, npm 2.1.8

I have two existing ember-cli projects which work fine. Now I created a new project (with ember new), and when I try to serve/build it I get the error

“File: my-project/app.js false == true AssertionError: false == true”

I then tried to take the whole folder of one on my existing projects (without node_modules etc.), copy it to a new location and run npm install & bower install - and I now get the same error there. Which seems kind of strange because it is the exakt same package.json and bower.json file.

At first I thought it could have something todo with ember-cli 0.1.5 and 0.1.6, which is already available. So I tried to upgrade, and had the exact same error (I then downgraded again).

I have never had any problems with ember-cli before, so I hope somebody can help me with this, because I have no idea what the problem might be.


#2

I am having the same problem on MacOS:

false == true
AssertionError: false == true
    at Visitor.PVp.visitWithoutReset

Seems to be some kind of dependency problem. Ticket here: Github


#3

Update: When I copy the whole node_modules folder from an existing project and overwrite the node_modules folder in my new project it works.


#4

I’m encountering the same problem (Linux) since a few hours ago. It could be some an update to one of the dependencies?


#5

Had the same problem, after downgrading ember-cli-esnext from 0.1.1 to 0.1.0 it works again.


#6

This is a known issue, fixed in Ember CLI 0.1.7.


#7

If you don’t want to or can’t update to ember-cli 0.1.7, swap "ember-cli-esnext": "0.1.1" with "ember-cli-6to5": "0.2.1" in your package.json and run npm install.

You’ll be golden.