Ember is hanging


#1

I’m having difficulties with ember hanging. Here’s my situation. • I’m running Mac OS 10.10.5, and homebrew package management. • >brew doctor —> Your system is ready to brew. • I was using nvm, but decided to remove it from the equation and simply do >brew install node@6 directly. • I’ve done a global install of ember-cli (2.10.1) and bower (1.8.0). • >ember new trippy <-- No problems • >cd trippy • >ember serve <-- Hangs, with no further feedback. • >ember build (and) >ember test <-- both also hang, with no further feedback.

I can do all of this on a different Yosemite system, with no problems. Also, checking my SSD drive with Disk Utility, shows no problems. If anyone has any ideas for me to try next, I’d appreciate them. I’m completely stuck, and unable to do anything ember related.


#2

Check your shell ulimit. It should allow more than 5000 file descriptors. It shouldn’t matter for new projects because there can’t be that many files, but good to check.


#3
> ulimit -a
-t: cpu time (seconds)              unlimited
-f: file size (blocks)              unlimited
-d: data seg size (kbytes)          unlimited
-s: stack size (kbytes)             8192
-c: core file size (blocks)         0
-v: address space (kbytes)          unlimited
-l: locked-in-memory size (kbytes)  unlimited
-u: processes                       709
-n: file descriptors                4864

I’m not sure how to increase it, however. Also, I’m pretty sure this hasn’t changed - ever, and I used to be able to use ember.


#4

Turns out, I needed to uninstall watchman from my system. Uninstalling it allowed ember serve, ember build and ember test to fall through whatever the hangup was. All complained about not being able to load watchman, of course, but they worked. I tried installing the latest of watchman, from github with > brew install --HEAD watchman, but it was no better.


#5

I tried installing the latest of watchman

Ah, I remember ember-cli doesn’t like the latest watchman (v4?). Try using it with watchman v3.0


#6

Easier said than done. Homebrew doesn’t appear to include any taps with older versions of watchman, and to prevent future problems, I’d prefer NOT to install it manually. (I’ll forget about it.) Thanks for the comment, though. I looked through the current issues on the watchman repo, and it appears there could be OS X issues which are causing this.


#7

After playing with dozens and dozens of Macs and solving problems on different dev environments, let say we kind of found the best way to install Node.js:

http://yoember.com/nodejs/the-best-way-to-install-node-js/

First of all, unfortunately brew is not your friend in this topic. I would suggest to uninstall the brew version of node and after install nvm manually with cloning the repository in your home folder. Add two lines of code to your .zshrc or .bashrc and you won’t have any problem ever with Node.js and with his peeps. :wink: